• If this is your first visit to the iboats.com Boating Forums, be sure to check out the FAQ. To post a question or comment, begin by signing up. To start viewing messages, select the forum that you want to visit from the selection below.
  • ALL iboats Forum Members and Guests:
    To show our appreciation for your participation in the Forums, we're offering an exclusive Forums-only discount good for an additional 5% off your iboats.com order for a limited time.
    To redeem, simply call our Customer Service Team at 800-914-1123 (Open M-F, 9am - 8pm Eastern Time) and mention the Forums 5% off discount. Offer excludes engines, trolling motors, and electronics.

Announcement

Announcement Module
Collapse
No announcement yet.

The boat has no power..

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts


  • The boat has no power..

    Hey guys I'm new on this site and new with boats as well. I recently bought myself a 1980 glastron crv 16' with a 175 mercury. I have hooked up water to the engine and ran it outside of my house and it ran great and sounded very strong, when I took the boat out to the lake i backed it into the water and the boat shut off.. and ever since there is no power at all.. Do you guys have any ideas what i should check or what i should do in order to get power back. I understand that it is hard to know for sure without looking at it but any information would be very appreciated.


  • #2
    Re: The boat has no power..

    I quess we could start with what you mean by "No Power At All". Do you mean the engine runs but has no power or do you mean you have no electrical power -- as in nothing electrical seems to work? There is a fuse(s) under the engine cowl and it may have blown. But generally a total loss of electrical power means the battery is bad, the connections to it are bad, the battery cable connections on the engine side are bad. Be a little more specific in your description of what is or is not happening.

    Comment



    • #3
      Re: The boat has no power..

      I sanded down all the elctrical conections and tightened everything and now I have electrical power again.. While the boat is out of the water it runs good in neutral and has no problem engaging in gear and reving rpm's but when the boat is in the water it doesnt want to stay running in neutral and when i engage it in gear the engine dies out.. like i said i am new at this but am very interested in working out all the bugs.. if you guys can possibly give me any ideas or what i should check next I would really appreciate it. Thank you for your time

      Comment



      • #4
        Re: The boat has no power..

        What type, make and model engine do you have? We need that to move this to the proper engine troubles forum.
        sigpic

        Comment

        Working...
        X