Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 2 of 2
  1. #1
    Petty Officer 1st Class
    Join Date
    May 2008
    Posts
    296

    Question How to properly fill the trim pump ?

    OK i have a mecruser outdrive. My question is can i take the fill screw out and run the pump ? I have to take the boat out in the lake to fill the resivior. ( to shallow at the dock)

    Is it ok to drive out. Stop with engine off. And take the screw out and fill the resivior. Then i was going to run the trim all the way up ( trailor mode) and down a few time with the screw out. Will it just spit the fluid out or will it pump right ?

    Reason is last time i filled it with the drive not all the way down. And when i took the fill screw out it spat at me. Also how do you bleed the system ??

    I think i have to get a new line. But want to make shure that the line i tightend last night wasnt the culprit.
    1979 MarkTwain V sonic Inline 6 165 HP

  2. #2
    Petty Officer 2nd Class
    Join Date
    Apr 2008
    Posts
    176

    Default Re: How to properly fill the trim pump ?

    I am having the same problem right now. I had to replace two trim lines on mine this spring. I though I had it all squared away, but now that its at the slip I can see that the outdrive is drifting up when it sits due to air in the lines. I ran mine with the fill screw out, but I think you're going to have to pull the boat to properly bleed it as I think you have to bleed the air at the trim cylinders. I could be wrong, but after looking over my system, thats the only way I can figure out how to do it.
    Chris
    '74 Century Raven Hardtop "Better 'n' Nuthin II"

    '94 Polaris SL750
    '94 Sea Doo GTX
    '95 Sea Doo XP

Similar Threads

  1. How do I properly service trim system??
    By sliznippa in forum Yamaha & Suzuki Outboards
    Replies: 1
    Last Post: October 20th, 2008, 07:46 AM
  2. Changed water pump, now won't idle properly
    By alhersch in forum Mercury & Mariner Outboards
    Replies: 3
    Last Post: August 13th, 2007, 04:21 PM
  3. bilge pump not working properly ?
    By slamer12 in forum Boat Topics and Questions (not engine topics)
    Replies: 4
    Last Post: May 25th, 2005, 05:16 AM
  4. Trim Pump Fluid change (or fill)
    By Bamagreg in forum Johnson & Evinrude Outboards
    Replies: 1
    Last Post: March 7th, 2005, 03:47 AM
  5. Is Oil Injection Pump Working Properly on 89 Merc.
    By danpcro in forum Mercury & Mariner Outboards
    Replies: 0
    Last Post: September 29th, 2004, 02:30 PM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic